Overview

This document and the associated MS Excel 2003 Sample workbooks are for primary use by first-time AES*XML Users who are using MS Excel spreadsheets to manage their Annual Emission Statement (AES) data.  It is intended as a primer document to get you started with the necessary data organization, XML mapping, and XML file generation.  It is not a comprehensive XML guidance document, nor does it replace the user help included in MS Excel.  It is only meant to give a few potential ways of getting started with forming your XML file.  

The content of the document is focused on the use of MS Excel 2003.  Although other, earlier versions of MS Excel support the use of XML, 2003 provides specific user interfaces and refined functionality that aids greatly in the forming of XML data sets.  This being said, there may be many other ways of creating a valid AES XML file using other versions of MS Excel or using Excel 2003.  It is intended that this document will provide a fair starting point for your mapping and creation of an AES submission using XML.

The document is organized into a few major sections.  The first section talks about how you might organize your current, raw AES data so that it is more readily formed into the required XML structure.  The second section walks through how to create a ‘map’ in Excel based on the AES XML schema provided by DEP.  The third highlights how to create the required AES XML ‘areas’ using the ‘map’ as the starting point.  Conversely, the next section provides an overview of mapping an XML section to existing data.  The fifth section discusses how to create an XML map for a single (non-repeatable) data element such as contact information.  The sixth section talks about how to export your data into an XML file that can be submitted to DEP.  Lastly, three final sections provide some guidance on importing and working with DEP code table data.  Following these sections, we provide a brief overview of the creation of an XML file without the use of the Excel tools.

Data Organization

The easiest way to get Excel data into XML is to properly organize and summarize the data into tables.  The AES schema consists of 7 sections: Submission Info, Fuel Usage Summaries, Emissions Summaries (facility-level), Fuel Tests, Schedules, Actual Emissions (source-level), and Miscellaneous Emissions.  The data elements that make up these sections are described in the schema and in the accompanying Data Mapping sheet.  It is suggested that you organize your data into 7 tables, each mimicking the structure of one of the 7 sections of the schema.

For example, you may have source-level emission amounts scattered throughout your current Excel workbook, perhaps to calculate them for each source or by pollutant.  We suggest that you create a new single table (perhaps as part of a new, separate tab), with a column for each of the elements in the ActualEmission XML grouping: SF_ID, SubFacilityID, SubFacilityName, PollutantAnalyteCode, CalculationMethodCode, and EmissionAmountTPY.  Then create a row in the table for each emission “record” you have and make cell references to the data in other sheets to fill in the columns.  For instance, if we have two boilers, 031 and 032, each emitting CO, NOX, and VOC, we would create 6 rows in the ActualEmission table and create references to the emission calculations for each source and pollutant.  An Example of this can be found in the Excel2003Example.xls and NonExcel2003Example.xls workbooks.

The table summary is fundamental to solutions using Excel 2003 and older versions of Excel.

Excel 2003 - Adding an XML Map (schema)

Excel 2003 has the ability to import an XML Schema file so users may map elements of the schema to worksheet data.  Although other earlier version of Excel can handle XML formation, Excel 2003 has a tool suite the makes the process more intuitive and powerful.  Although you are welcome to use other methods for adding an XML map in Excel 2003, our approach is as follows:

1. Save the latest version of the Annual Emission Statement (AES) schema file (aes.xsd) provided by DEP to your hard drive or to an accessible folder on your network

2. Open your Excel workbook in Excel 2003.

3. Click on the Data menu, mouse over ‘XML’ to open the submenu and choose the ‘XML Source’ menu item.  This should show the XML Source Task Pane on the right side of the Excel window.

4. Click the ‘XML Maps’ button near the bottom of the Task Pane.  This will open the XML Maps dialog window.

5. Click the ‘Add’ button near the bottom of the XML Maps dialog.  This will open the Select XML Source dialog window.

6. Browse to and select the AES schema file (aes.xsd) that you saved previously and click ‘Open’.  This should add a new XML Map with a name of “AnnualEmissionStatement_Map” and a root of AnnualEmissionStatement

7. Click ‘Ok’ to accept the new map and return to your work sheet.  The new map should now appear as a “tree” in the Task Pane.

Excel 2003 - Creating Areas for Mapping from Schema (Recommended Method)

After adding a map to your workbook, Excel 2003 allows you to create tables or “lists” for entering data into XML structures.  This is a quick and easy way to create the tabular data structures described in the Data Organization section of this document.

1. If you have not done so already, complete the “Adding an XML Map (schema) to Excel 2003” section above in your workbook.

2. Create a new worksheet for a section (e.g., Fuel Usage Summary, Emission Summary, Fuel Tests, etc.) of the AES schema/report.

3. If the Task Pane is not visible, click on the Data menu, mouse over ‘XML’ to open the submenu and choose the ‘XML Source’ menu item.

4. Locate the map section in the Task Pane that corresponds to section (new worksheet) of data with which you are working (e.g., Fuel Usage Summary, Emission Summary, Fuel Tests, etc.).

5. Click on the section group name (i.e., FuelTest) in the map and drag it to the area of the worksheet where you would like to create the table.  Dropping it on the worksheet should create a new table or list with column headings matching the elements of the section you selected …
--- OR ---
Right click on the section group name (i.e., FuelTest) and choose ‘Map Element….’  This will open a dialog that will allow you to type in or select the area you would like to use.

This should create a List, represented with a blue line around it and an ‘add row’ with an asterisk in it.  All data added to this List area will be exported to the mapped XML section. 

Tip:  If you’ve mapped something incorrectly and would like to remove the mapping, simply Right click on the section or element you would like to unmap in the Task Pane and choose ‘Remove Element’.

Excel 2003 - Mapping an XML Section to existing data

Before attempting to map an area of existing data, you will need to be sure that the data matches the XML section element-for-element.  For example, you would need to have already created Pollutant Analyte Code and Emission Amount columns beside each other if you want to map to the EmissionSummary section of the XML schema.  Data may already be present and/or can be added later.  Once these columns are created, the mapping process is the same as creating one from scratch:

1. If you have not done so already, complete the “Adding an XML Map (schema) to Excel 2003” section above in your workbook.

2. If the Task Pane is not visible, click on the Data menu, mouse over ‘XML’ to open the submenu and choose the ‘XML Source’ menu item.

3. Locate the map section in the Task Pane that corresponds to section (new worksheet) of data with which you are working (e.g., Fuel Usage Summary, Emission Summary, Fuel Tests, etc.).

4. Click on the section group name (i.e., FuelTest) in the map and drag it to the area of the worksheet where you would like to create the table.  Dropping it on the worksheet in the upper left corner of your existing data table should map the table
--- OR ---
Right click on the section group name (i.e., FuelTest) and choose ‘Map Element….’  This will open a dialog that will allow you to type in or select the area you would like to use.

This should create a List, represented with a blue line around it and an ‘add row’ with an asterisk in it.  All data added to this List area will be exported to the mapped XML section. 

Excel 2003 - Creating a mapping for a single element

For the SubsmissionInfo section, you may want to map the individual data elements to single cells in your worksheet.  Non-repeating data such as this will not use an XML mapping list and is mapped only once.

1. If you have not already, complete the “Adding an XML Map (schema) to Excel 2003” section above in your workbook.

2. If the Task Pane is not visible, click on the Data menu, mouse over ‘XML’ to open the submenu and choose the ‘XML Source’ menu item.

3. Locate the map section in the Task Pane that corresponds to section (new worksheet) of data with which you are working (e.g., Fuel Usage Summary, Emission Summary, Fuel Tests, etc.).

4. Click on the element name (i.e., PrimaryFacilityName) and drag it to the cell in the worksheet to which you would like to map.  Dropping it on the worksheet in the cell containing your existing data should map the cell.

--- OR ---
Right click on the element name, i.e. PrimaryFacilityName, and choose “Map Element….”  This will open a dialog that will allow you to type in or select the cell you would like to use.

An example of the SubmissionInfo mapping can be found on the SubmissionInfo tab of the Excel2003Example.xls workbook.

Excel 2003 - Exporting XML Data

Once all of your data elements have been mapped, perform the following steps to export your data to XML:

1. If you have not done so already, complete the ‘Adding an XML Map (schema) to Excel 2003’ section highlighted above in your workbook.

2. If the Task Pane is not visible, click on the Data menu, mouse over ‘XML’ to open the submenu and choose the ‘XML Source’ menu item.

3. (Optional) Click on the ‘Verify Map for Export…’ link at the bottom of the Task Pane.  This will tell you if the data has been properly mapped and it can be exported to XML.

4. Click on the Data menu, mouse over ‘XML’ to open the submenu and choose the ‘Export…’ menu item.  This should open the Export XML dialog box.

5. Browse to a folder on your machine or network to which you wish to export (store) your xml file, type in a file name ending in “.xml” and click ‘Export’.

6. After export, the file can opened and viewed in Internet Explorer or your preferred XML editor.

A Non Excel 2003 Example

Older versions of Excel do not have the sophisticated mapping capabilities and tools that Excel 2003 does, but we can still achieve the desired results.  XML files are special in structure, requiring specific tags in the proper order to identify data, but in the end they are simple text files.  We can use this fact, along with string concatenation in Excel, to create XML.   After you’ve organized your data into table as described in the ‘Data Organization’ section above, you can build formulas that surround your data elements with the appropriate XML tags (specified in the AES schema provided by DEP).  For example, to create an emission summary XML record, the formula would look something like the following:

="<EmissionSummary><PollutantAnalyteCode>" & A3 & "</PollutantAnalyteCode><EmissionAmountTPY>" & B3 & "</EmissionAmountTPY></EmissionSummary>"

This assumes A3 and B3 contain the DEP Analyte Code and Emission amount, respectively.  The ‘&’ adds the XML tag strings together to with the data in the cells to form a single XML row that looks like this:

<EmissionSummary><PollutantAnalyteCode>5</PollutantAnalyteCode><EmissionAmountTPY>1254.26</EmissionAmountTPY></EmissionSummary>

Please note:  XML ignores most white space (consecutive spaces, carriage returns, tabs, etc.), so it is perfectly fine to have an entire grouping on a single line like this.
An example of this can be found in column C on the ‘EmissionSummary’ tab of the NonExcel2003Exmaple.xls workbook.  If we repeat this for each row in each section of the XML schema, we have the building blocks for the file.  The next step would be to create a single worksheet that brings all of the sections together in the correct order.  An example of this sheet can be found on the ‘XML Out’ tab of the NonExcel2003Example.xls workbook.

To export the XML data from Excel using this scenario, complete the following steps:

1. Open your Excel workbook.

2. Open up Notepad (or your favorite text editor).

3. Go back into Excel and select the ‘XML Out’ worksheet (or your equivalent).

4. Copy all of the data on the worksheet to the clipboard.
Tip: an easy way to select the entire worksheet is to click the blank box in the upper left corner of the sheet, to the left of the column A heading.

5. Switch back to Notepad and paste the contents of the clipboard in to it.

6. Choose ‘Save As …’ from the Notepad File menu and save the file as ‘aes.xml’ into a folder on your hard drive.

7. This file may then be opened in Internet Explorer or your preferred XML editor for viewing.

Working with the DEP Code Tables

Importing DEP Code Tables

In order to ensure that a complete data set is sent to DEP, it is critical that certain data like Pollutants, Fuel Types, Units of Measure, Calculation Methods, etc. use DEP codes rather than your codes or descriptions.  To help you use the DEP codes, the AES*XML application provides the capability for you to download all the required DEP code tables for use in your application or spreadsheet.  Since it is very important that you provide the correct codes you may want to consider building an automated way to look up these codes using Excel functionality.

To import the Code tables into Excel, complete the following steps:

1. Download the code tables from the Download Code Tables screen in the AES*XML application.  Download the files in CSV (comma-separated value) format.
Please Note:  If clicking the CSV link does not provide an option to download the file, right click on the link and choose ‘Save Target As...’
2. Open your Excel workbook.
3. Click on the File Menu in Excel and choose ‘Open…’  This should open the Open dialog window.

4. Choose ‘Text Files’ from the ‘Files of type’ drop-down near the bottom of the Open dialog

5. Browse to and select the CSV file you would like to import and click ‘Open’.  This should open the contents of the CSV file in its own worksheet in a new workbook.

6. Right click on the tab at the bottom of the new worksheet and choose ‘Move or Copy…’ from the resulting pop-up menu.  This should bring up the ‘Move or Copy’ dialog box

7. Choose your workbook from the ‘To book’ dropdown.

8. Select a sheet in your workbook in the ‘Before sheet’ list to specify where the new tab will be placed.

9. Leave the ‘Create a Copy’ checkbox unchecked

10. Click ‘OK’.  This should close the new workbook created for the CSV file and move the worksheet into your workbook.

11. Save your workbook.

Working with DEP Code Tables using Excel Formulas

After you’ve imported the code tables into Excel, the data in them can be looked up and referred to throughout your workbook.  For example, you may want to enter the name of a Unit of Measure for readability, but you still need the code to create the file.  Excel has a function called ‘LOOKUP’ that will find a value in one list and return the corresponding value from another list.  In this example, the UOM name would be looked up from one list and the code looked up from the other.  This concept is used for Throughput UOM, Analyte Code, and Calculation Method Code on the CU 031 and CU032 tabs of the Excel2003Example.xls and NonExcel2003Example.xls workbooks.

If it is a requirement that you keep your names for certain data elements, you could add another column to the DEP code tables to add your names and effectively “map” your names to the DEP codes.  Creating this mapping would allow you to still use the lookup function and keep your data relatively intact.

Manually Working with DEP Code Tables

For smaller sites or limited variations of data, creating automated ways of looking up codes and identifiers may be overkill.  Instead, you may choose to simply manually add code table data to your workbook at the appropriate places.  For instance, throughout your workbook you may refer to Carbon Monoxide as “CO”.  However, the XML file requires that you report the DEP code for Carbon Monoxide, the number 6.  It is suggested that wherever you refer to data such as Pollutants by name, that you create an adjacent cell or column to add the DEP code for that piece of data.  In our example, you would look up Carbon Monoxide in the Code Table and enter 6 in the cell beside it.  Later, when mapping data to the summary sheets, refer to the cell with the code in it instead of the name.

Tips and Resources

Although DEP is prohibited from endorsing any particular tool, the list below contains references to commonly used resources.

· Internet Explorer can be used as a simple XML file viewer

· Notepad can be used as a simple XML editor

· XML Spy – Home Edition
http://www.altova.com/download_spy_home.html
· XML Tutorial From Microsoft (Requires Office 2003 to run) http://office.microsoft.com/training/Training.aspx?AssetID=RC011304651033&CTT=6&Origin=RC011304651033
· XML in Excel 2003 Tutorial (Requires Office 2003 to run)
http://office.microsoft.com/training/training.aspx?AssetID=RC011310531033
· IBM’s Intro to XML
http://www-106.ibm.com/developerworks/education/xmlintro/xmlintro.html
· An Independent Intro to XML
http://www.xmlfiles.com/xml/
· A more technical view
http://www.xml.com/pub/a/98/10/guide0.html
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